One of the main reasons why the pixel is not showing inside our Connectio tool is that the pixel you've installed on your website is not assigned to your ad account. 


To assign your Facebook Pixel to your Ad Account, follow the steps below.


Step 1. Go to the pixels section on your Facebook Ads Manager. (“Data Sources” > “Pixels”)


Step 2. Select the Pixel that you’d like to assign Ad Accounts to.

 


Step 3. Check if your personal account has been added as “Manage Pixel” in your Pixel. If not, please click “Add People” and select related individuals as the “Manage Pixel”.



Step 4. Turn on “Manage Pixel” to create, edit, and view pixels.



Step 5. Click “Add Assets” and select the Ad Accounts you want to assign your Facebook Pixel to. Click “Add” and Done.





Step 6. Click the “Connected Assets” tab to check if the Pixel is successfully connected to Ad accounts.

 


I've done that and my pixel is still not showing on ConncetRetarget, what's next?

You need to refresh the API connection between Connectio and Facebook. To do that, please follow the instruction in the "How can I disconnect or switch to another Facebook account?" article.
 
If you’ve tried the above steps and still getting the same issues, please contact our support, and will be happy to help and investigate the issue further.

How to get your support tickets resolved faster


Statistics have shown us that the more you tell us when you report an issue, the faster we solve that ticket. So...


1 - If you have screengrabs, please include them. A picture is worth a thousand words.


2 - If you have recorded a video showing the issue you're having, please include that as well. A video is worth a million words.

We recommend a free service called Loom for creating these videos. (this is a link to useloom.com)


3 - To speed up ticket resolution, follow these useful tips How to Write the Perfect Support Ticket (That Gets Results Fast)