When you say your Facebook Lead Ad isn't working, you probably one of these two things:


#1: When you (or someone else) clicks on your Facebook Lead Ad, the Facebook Form doesn't show up.


Or

#2: The form does show up, but when you submit the form the email address isn't submitted into your email list or autoresponder.

Both issues have different reasons, which is what we'll go into in this article.

Problem #1: Your Lead Form doesn't show up when you click on your Lead Ad


How to recognize this issue?
When you (or someone else) clicks on the message, you will be linked to your website (instead of opening your lead form).

How to fix the issue?
When testing our Facebook Lead Forms you can only enter each Lead Form once per FB Account.

This means if you try to submit the same Lead Form the 2nd time around, Facebook will not open the Lead Form. Instead, they'll send you to the website.

This means if you want to try multiple times, you'll have to either test from another FB account or create a new Lead Form to test. The second time when you click on a Lead Ad from the same account, it will simply open up the link instead of opening up the Lead Form.


Problem #2: Your Leads are not being added to your email list


How to recognize the issue?

When someone submits your lead form, and their email address is not being added to your email list.


How to fix the issue?


There can be multiple reasons why this is happening, which is why we've created a checklist for this.


Check 1 - Have you connected the (right) lead form using ConnectLeads?


Check 2 - Do you have double opt-in turned on?


In case you have double opt-in turned on at your autoresponder, every new subscriber will need to confirm their email address first.


Until they confirm their email, they will not appear inside your email list.


This is the most common issue when not all emails are added to your autoresponder.


Read more about disabling double opt-in here.


Check 3 - Do you have any "required fields" configured at your autoresponder?


In some cases people have set up "required fields" at their autoresponder, meaning that new subscribers need to have information in order for them to be added.


For example, a lot of Mailchimp users automatically have the "First Name" set as required. When ConnectLeads then submit their "Full Name" instead, Mailchimp will automatically ignore the new lead and won't add it to your email list.


As a solution, please make sure no fields (besides "email") are configured as "required" at your email list.


Here's how to disable the requirement in case you are using Mailchimp: